Global: Xero- some customers are experiencing issues in using Xero.

Incident Report for Xero

Update

We've resolved the issue experienced by a small section of customers when navigating Xero.

Xero is now stable and customers should be able to use the platform normally. Our engineering teams will continue to monitor closely for stability and to ensure everything remains on track. We appreciate your patience and will provide a further update if necessary.
Posted May 08, 2026 - 15:01 UTC

Update

We're aware that a smaller section of customers are experiencing issues navigating Xero following the third-party hardware issue with AWS that impacted our platform. We're investigating this with urgency.
Posted May 08, 2026 - 11:49 UTC

Update

Xero is now stable and customers should be able to use the platform normally. Our engineering teams will continue to monitor closely for stability and to ensure everything remains on track. We appreciate your patience and will provide a further update if necessary.
Posted May 08, 2026 - 12:26 UTC

Monitoring

Our technical teams have implemented a fix following a third-party hardware issue with AWS that impacted our platform. Customers should now be able to use Xero without issue. We'll be closely monitoring performance over the next 48 hours and throughout next week.
Posted May 08, 2026 - 03:47 UTC

Identified

We're aware some customers are experiencing errors when logging in or navigating areas of Xero. This is not related to the recent platform issues which remain on track. The current issue relates to a third-party hardware incident that has impacted us. We are working closely with them to resolve this as soon as possible and will provide further updates as we have them. We apologise for the continued disruption.
Posted May 08, 2026 - 01:05 UTC

Update

We are continuing to investigate this issue.
Posted May 08, 2026 - 00:05 UTC

Investigating

We are aware that customers trying to navigate in Xero are experiencing some errors. Our team is investigating this with urgency. We will provide further updates as soon as we have more information.
Posted May 07, 2026 - 23:49 UTC

Update

We apologise for the disruption this week. This is complex work and we are being deliberate to avoid further issues downstream. Improvements have been deployed overnight and we are continuing to monitor closely for any further issues. Thank you for your patience as we work through this fix.
Posted May 07, 2026 - 22:01 UTC

Update

We are continuing to monitor for any further issues.
Posted May 07, 2026 - 14:13 UTC

Monitoring

We've implemented a fix and customers should now be able to log in to Xero. We're continuing to monitor the situation. We apologise for the inconvenience this disruption may have caused and genuinely appreciate your patience.
Posted May 07, 2026 - 02:20 UTC

Investigating

We are aware that customers trying to navigate in Xero are experiencing an error. Our team is investigating this with urgency.
Posted May 07, 2026 - 01:39 UTC

Monitoring

Our team has implemented a fix and we are currently monitoring the results.
Posted May 07, 2026 - 01:03 UTC

Identified

We are aware customers trying to use Xero are experiencing errors. Our team is investigating this with urgency.
Posted May 07, 2026 - 00:33 UTC
This incident affects: Xero Platform and Settings and Xero Partner Products & Tools (Xero Practice Manager (XPM)).