Some users will experience slowness or errors when accessing or using Xero, and Xero Practice Manager
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was preventing users from accessing, and navigating around Xero, and Xero Practice Manager.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted 4 months ago. May 04, 2018 - 18:15 NZST
Update
We’re closer to sorting this out, sorry for the disruption this is causing you.
Posted 4 months ago. May 04, 2018 - 17:37 NZST
Identified
We're working to restore your ability to access, and move around Xero, and Xero Practice Manager as soon as possible.
Posted 4 months ago. May 04, 2018 - 16:50 NZST
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted 4 months ago. May 04, 2018 - 16:29 NZST
Investigating
We’re currently aware of an issue preventing users from accessing, and navigating around Xero, and Xero Practice Manager. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted 4 months ago. May 04, 2018 - 16:12 NZST