Australia: Xero Tax - increased processing times when filing

Incident Report for Xero

Resolved

Our team has resolved an issue causing increased processing times when filing in Xero Tax, which was resolved before EOD. If you have any questions, please raise a case with our Xero Support team. We apologise for any inconvenience caused.
Posted May 15, 2025 - 13:34 UTC

Monitoring

Our team has made some changes to improve processing time and we are currently monitoring the results.

Status Last Reviewed: 09:18 UTC.
Posted May 15, 2025 - 09:18 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 15, 2025 - 07:36 UTC

Identified

We’re aware some customers are experiencing increased processing times when filing in Xero Tax. Our team is investigating with urgency. Thanks for your patience.
Status Last Reviewed: 2:03am UTC
Posted May 15, 2025 - 00:52 UTC
This incident affected: Xero Platform and Settings and Xero Partner Products & Tools (Xero Tax (AU)).