Some users are experiencing slowness and errors in Xero
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was causing errors and performance issues in Xero.

If you're still having any problems, please clear your browser's cookies and cache. Let us know if you continue to have issues, and we'll investigate further.
Posted Jul 22, 2020 - 01:45 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2020 - 23:30 UTC
Update
A fix has been implemented and we are monitoring the results. Thanks for your patience.
Posted Jul 21, 2020 - 23:16 UTC
Update
We are continuing to investigate this issue.
Posted Jul 21, 2020 - 23:13 UTC
Investigating
We’re currently aware of an issue preventing access to Xero. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Jul 21, 2020 - 23:11 UTC
This incident affected: Xero Platform and Settings.