Global: Xero - Customers may be experiencing slowness
Incident Report for Xero
Resolved
Our team has resolved the performance issues some customers experienced across Xero. We apologise for any inconvenience this has caused.

Our technical team identified this was caused by poor network connectivity and has restored service.
Posted Dec 18, 2023 - 01:47 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 12:39am UTC
Posted Dec 18, 2023 - 00:39 UTC
Identified
We have identified what is causing degraded performance in Xero.

This is our top priority and we will update you as soon as we can.

Status Last Reviewed: 11:42pm UTC
Posted Dec 17, 2023 - 23:43 UTC
Investigating
We are aware some customers may be experiencing slowness in Xero. Our team is investigating this with urgency.

Status Last Reviewed: 11:11pm UTC
Posted Dec 17, 2023 - 23:11 UTC
This incident affected: Xero Platform and Settings.