Global: Login - customers may be unable to login to Xero
Incident Report for Xero
Resolved
Akamai has resolved the issues on their end that were impacting some customers trying to login to Xero. Please see the Akamai status page for further details about this issue. https://www.akamaistatus.com/

We apologise for any inconvenience this has caused.
Posted Feb 27, 2023 - 20:09 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 8:02pm UTC
Posted Feb 27, 2023 - 20:02 UTC
Investigating
We are aware customers trying to login to Xero are currently experiencing issues. Our team is investigating this with urgency.

Status Last Reviewed: 7:44pm UTC
Posted Feb 27, 2023 - 19:45 UTC
This incident affected: Xero Platform and Settings.