Scheduled Xero system maintenance
Incident Report for Xero
Resolved
The scheduled maintenance has been completed.
Posted Mar 21, 2021 - 07:30 UTC
Monitoring
Scheduled maintenance is currently in progress until 8am Sunday 21 March UTC.
Posted Mar 20, 2021 - 19:00 UTC
Investigating
Xero will be conducting system maintenance from 7:00 pm Saturday, 20 March UTC to 8:00 am Sunday, 21 March UTC.

We don’t expect there to be any delays during this time, and our team will be monitoring the performance of the Xero platform. We apologise for any inconvenience.
Posted Mar 19, 2021 - 00:29 UTC
This incident affected: Xero Platform and Settings.