Customers experiencing issues accessing Xero, and general slowness across the platform
Incident Report for Xero
Resolved
Our team has resolved the issue causing general slowness across the Xero platform and impacting customers from receiving emails from Xero, including emails relating to multifactor authentication. We apologise for any inconvenience this has caused. Please note that there may be a delay in emails sending as the system catches up.
Posted Dec 21, 2022 - 09:58 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 07:13 UTC
Posted Dec 21, 2022 - 07:13 UTC
Identified
We have identified what is causing customers to experience issues and general slowness across Xero.

This is our top priority and we will update you as soon as we can.

Status Last Reviewed: 05:36 UTC
Posted Dec 21, 2022 - 03:37 UTC
Update
Our technical team is continuing to work on this.

We are also aware this is impacting customers from receiving emails from Xero, including emails relating to multifactor authentication.
Posted Dec 21, 2022 - 01:31 UTC
Investigating
We are aware customers are experiencing general slowness across the Xero platform. Our team is investigating this with urgency.
Posted Dec 20, 2022 - 22:30 UTC
This incident affected: Xero Platform and Settings.