Xero Community page - Users are unable to access the Xero Community page
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was preventing users from accessing Xero Community.
Posted Apr 14, 2021 - 13:09 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2021 - 12:11 UTC
Investigating
We are currently investigating this issue.
Posted Apr 14, 2021 - 11:19 UTC
This incident affected: Xero Central.