Global: Projects - Customers are experiencing errors trying to create or edit projects

Incident Report for Xero

Resolved

Our team has resolved the issue impacting customers trying to create or edit Projects. We apologise for any inconvenience this has caused.
Posted Aug 20, 2025 - 08:49 UTC

Monitoring

Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 8.08am UTC
Posted Aug 20, 2025 - 08:09 UTC

Identified

We have identified what is preventing customers from creating or editing Projects in Xero. Our team is investigating this with urgency.

This is our top priority and we will update you as soon as we can.

Status Last Reviewed: 8am UTC
Posted Aug 20, 2025 - 08:00 UTC

Investigating

We are aware customers trying to create or edit Projects in Xero are experiencing errors. Our team is investigating this with urgency.

Status Last Reviewed: 7.41am UTC
Posted Aug 20, 2025 - 07:41 UTC
This incident affected: Core Xero Products (Projects).