Global: Xero - Customers may be experiencing errors in Xero

Incident Report for Xero

Resolved

Our team has resolved the issue impacting customers trying to navigate multiple products in Xero. This was caused by an unexpected database issue during routine maintenance. We apologise for any inconvenience caused.
Posted Jul 22, 2025 - 19:48 UTC

Investigating

We are aware customers trying to navigate across multiple products in Xero are experiencing errors. Our team is investigating this with urgency.
Posted Jul 22, 2025 - 19:30 UTC
This incident affected: Xero Platform and Settings.