NZ: Xero Mail - Some Xtra Mail customers failed to receive emails
Incident Report for Xero
Resolved
We are aware that customers attempted to send emails from Xero via Xero Mail were failing to send to customers with Xtra email addresses. This issue impacted customers intermittently between 12pm, 5 May - 2.30pm, 9 May NZT.

This issue is now resolved however we recommend that any emails sent during this time that failed to be sent to the recipient are resent by Xero.

We apologise for the inconvenience that this issue caused.
Posted May 08, 2024 - 08:04 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 08, 2024 - 08:01 UTC
Identified
We have identified what is impacting some customers from receiving emails from Xero.

This is our top priority and we will update you as soon as we can.

Status Last Reviewed: 7:46am UTC.
Posted May 08, 2024 - 07:46 UTC
Investigating
We are aware some Xtra Mail customers may be experiencing an issue receiving emails. Our team is investigating this with urgency.

Status Last Reviewed: 7:42am UTC
Posted May 08, 2024 - 05:08 UTC
This incident affected: Xero Platform and Settings.