Malaysia and Singapore customers may be unable to access Bills to Pay
Incident Report for Xero
Resolved
We have resolved the issue that was preventing some Malaysian and Singaporean customers from accessing the Bills to Pay feature. This issue was caused by a product release and we apologise for any inconvenience.
Posted Nov 09, 2022 - 02:21 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 09, 2022 - 01:11 UTC
Investigating
We're aware of an issue where some customers are unable to access the Bills to Pay page in Malaysia and Singapore. Our team is investigating this with urgency.

Status Last Reviewed: 1:10am UTC
Posted Nov 08, 2022 - 03:48 UTC
This incident affected: Core Xero Products (Invoicing, Bills & Quotes).