Xero HQ - client list is down

Incident Report for Xero

Resolved

Customers are now able to access the Xero HQ Client List. Our team has resolved the issue impacting customers trying to access the Xero HQ Client List which was caused by a prior release that our technical team rolled back. We apologise for any inconvenience this has caused.
Posted Dec 20, 2022 - 22:12 UTC

Monitoring

Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 21:58 UTC
Posted Dec 20, 2022 - 21:58 UTC

Investigating

We are aware customers are unable to access their Client List on Xero XQ. Our team is investigating this with urgency.

Status Last Reviewed: 21:47 UTC
Posted Dec 20, 2022 - 21:47 UTC
This incident affected: Xero Partner Products & Tools (Xero HQ).