Global: Hubdoc - Customers may experience a delay in publishing documents to Xero

Incident Report for Xero

Resolved

Our team has resolved the issue impacting customers trying to publish documents to Xero in Hubdoc. We apologise for any inconvenience this has caused.

This was caused by a system error and the team implemented a fix to resolve the issue.
Posted Mar 18, 2025 - 18:55 UTC

Monitoring

Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 6:38pm UTC
Posted Mar 18, 2025 - 18:38 UTC

Identified

We have identified what is impacting customers trying to publish documents to Xero in Hubdoc.

This is our top priority and we will update you as soon as we can.

Status Last Reviewed: 6:15pm UTC
Posted Mar 18, 2025 - 18:16 UTC

Investigating

We are aware customers trying to publish documents to Xero in Hubdoc are experiencing delays. Our team is investigating this with urgency.

Status Last Reviewed: 5:28pm UTC
Posted Mar 18, 2025 - 17:28 UTC
This incident affected: Hubdoc.