Global: Navigation- customers unable navigate in Xero
Incident Report for Xero
Resolved
A third party issue with Crowdstrike impacting global Xero customers has now been resolved. We apologise for any inconvenience caused, and we thank customers for their patience during this time.
Posted Jul 19, 2024 - 08:03 UTC
Update
We are aware some customers are experiencing issues navigating in Xero as a result of a third party issue with Crowdstrike.

We thank customers for their patience while we investigate and apologise for any inconvenience.
Posted Jul 19, 2024 - 07:30 UTC
Identified
We are aware some customers are experiencing issues navigating in Xero as a result of a third party issue with Crowdstrike.

We thank customers for their patience while we investigate and apologise for any inconvenience.
Posted Jul 19, 2024 - 06:27 UTC
Update
We are aware global customers trying to navigate in Xero are experiencing issues. Our team is investigating this with urgency.

Status Last Reviewed: 6:08am UTC
Posted Jul 19, 2024 - 05:55 UTC
Investigating
We are aware global customers trying to see the Navigation menu in Xero are experiencing a blank page. Our team is investigating this with urgency.

Status Last Reviewed: 5:42am UTC
Posted Jul 19, 2024 - 05:42 UTC
This incident affected: Xero Platform and Settings.