Xero Files - customers unable to access or retrieve files
Incident Report for Xero
Resolved
Our team has resolved the issue impacting customers from retrieving or accessing files. This related to some network connectivity errors that our systems experienced which our team have resolved. We apologise for any inconvenience this has caused.
Posted Apr 29, 2023 - 18:30 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 6.20pm UTC
Posted Apr 29, 2023 - 18:20 UTC
Investigating
We are aware some customers are currently unable to access or retrieve Xero Files. Our team is investigating this with urgency.

Status Last Reviewed: 5.32pm UTC
Posted Apr 29, 2023 - 17:32 UTC
This incident affected: Core Xero Products (Files).