Some users are experiencing slowness and errors when accessing Xero
Incident Report for Xero
Resolved
This incident has been resolved.
Posted Jul 21, 2020 - 17:38 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2020 - 14:18 UTC
Update
Our Product Team are doing everything they can to resolve any performance issues you are experiencing. Thanks for your patience.
Posted Jul 21, 2020 - 13:00 UTC
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted Jul 21, 2020 - 12:00 UTC
Investigating
We are currently investigating this issue.
Posted Jul 21, 2020 - 10:56 UTC
This incident affected: Xero.