Hubdoc - some customers currently experiencing issues
Incident Report for Xero
Resolved
Our team has resolved the issue that has been impacting Hubdoc. This issue related to network connectivity issue which our team was able to implement a fix which resolved customer impact. We apologise for any inconvenience this has caused.
Posted Feb 16, 2024 - 05:08 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 4.57am UTC
Posted Feb 16, 2024 - 04:57 UTC
Identified
We have identified the cause of these issues impacting Hubdoc.

This is our top priority and we will update you as soon as we can.

Status Last Reviewed: 3.55am UTC
Posted Feb 16, 2024 - 03:56 UTC
Investigating
We are aware that customers may be experiencing issues with Hubdoc. This relates to longer than expected document extraction times. There is also an issue that is impacting our CX team's ability to respond to customer raised cases.

We are working on this with high priority, and we apologise for any inconvenience.
Posted Feb 16, 2024 - 03:34 UTC
This incident affected: Hubdoc.