Our team has resolved the issue impacting Xero Files. This was caused by a product release, which has been rolled back to resolve customer impact. We apologise for any inconvenience caused.
Posted Feb 18, 2025 - 12:45 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.
Status Last Reviewed: 11:59 UTC.
Posted Feb 18, 2025 - 11:59 UTC
Investigating
We are aware that some customers trying to use Xero Files are experiencing errors or poor performance. This relates to Xero features that uses files including (but not limited to) expenses, Workpapers, emailing invoices and downloading bills. Our team is investigating this with urgency.
Status Last Reviewed: 11:48 UTC.
Posted Feb 18, 2025 - 11:08 UTC
This incident affected: Core Xero Products (Files).