Xero HQ - Customers are currently unable to invite staff members
Incident Report for Xero
Resolved
Staff members can be invited into Xero HQ once again. We have resolved the problem which was related to a product release and apologise for any inconvenience experienced.
Posted Oct 31, 2022 - 01:52 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 1:25am UTC
Posted Oct 31, 2022 - 01:25 UTC
Investigating
We are aware customers trying to invite new staff members in Xero HQ are receiving errors. Our team is investigating this with urgency.

Status Last Reviewed: 11:39pm UTC
Posted Oct 30, 2022 - 23:39 UTC
This incident affected: Xero Partner Products & Tools (Xero HQ).