Some users are experiencing slowness in some areas of Xero
Incident Report for Xero
Resolved
This incident has been resolved.
Posted Jun 10, 2021 - 07:47 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 10, 2021 - 06:14 UTC
Investigating
We're aware some users are experiencing issues loading the users screen, and some slowness in areas of Xero.

Our team are investigating and we will post updates here.
Posted Jun 10, 2021 - 05:39 UTC
This incident affected: Xero Platform and Settings.