Some users experiencing performance issues in Xero
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was causing login or performance issues for some users in Xero.

Please let us know if you still have any issues accessing Xero, and we’ll investigate further.
Posted Mar 31, 2021 - 23:43 UTC
Update
Our Product Team are doing everything they can to get you back up and running. Thanks for your patience.
Posted Mar 31, 2021 - 23:16 UTC
Investigating
We’re currently aware of an issue causing login or performance issues for some users in Xero. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Mar 31, 2021 - 22:39 UTC
This incident affected: Xero Platform and Settings.