XPM - Some customers may experience issues
Incident Report for
Xero
Resolved
This incident has been resolved.
Posted
Sep
08
,
2023
-
00:20
UTC
Investigating
We are aware customers trying to navigate in XPM are experiencing issues. Our team is investigating this with urgency.
Status Last Reviewed:
12:12am UTC
Posted
Sep
08
,
2023
-
00:12
UTC
This incident affected: Xero Partner Products & Tools (Xero Practice Manager (XPM)).
×
Subscribe to Incident
Subscribe to updates for
XPM - Some customers may experience issues
via . You'll receive .