UK : UK Tax - Issues when loading filings

Incident Report for Xero

Update

We know some customers are still experiencing slowness when trying to load filings in Xero Tax for Corporation Tax or filing Statutory accounts. Our technical teams are continuing to work hard to resolve the issue and we apologise for the inconvenience caused.

For those only needing to file accounts you can try our new offering as an alternative : https://central.xero.com/s/article/Generate-incorporated-accounts#Startanewfiling
Posted Jun 30, 2026 - 16:52 UTC

Investigating

We are aware some UK customers are experiencing slowness or errors when loading filings in UK Tax. Our team is investigating this with urgency.
Posted Jun 30, 2026 - 16:41 UTC
This incident affects: United Kingdom - Regional Products (Tax Reporting - UK VAT & MTD).