Some users are experiencing slowness and errors when using Payroll in Xero
Incident Report for Xero
Resolved
Our Product Team have resolved the issue with Payroll. Please let us know if you still have any issues with this, and we’ll investigate further.
Posted about 1 month ago. Oct 16, 2018 - 19:34 NZDT
Update
We’re closer to sorting this out, sorry for the disruption this is causing you.
Posted about 1 month ago. Oct 16, 2018 - 18:48 NZDT
Identified
Our Product Team have identified the cause, and are working to restore performance for the affected users as soon as possible.
Posted about 1 month ago. Oct 16, 2018 - 18:34 NZDT
Update
Fixing this issue is our top priority right now, as we can appreciate the impact this is having for our users.
Posted about 1 month ago. Oct 16, 2018 - 18:23 NZDT
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted about 1 month ago. Oct 16, 2018 - 18:07 NZDT
Update
We’re currently aware of an issue causing slowness and errors when using Payroll in Xero. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted about 1 month ago. Oct 16, 2018 - 18:02 NZDT
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Oct 16, 2018 - 17:54 NZDT
This incident affected: Xero.