UK VAT Return not loading for some MTD Users
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was preventing some users from loading their VAT Returns.

Please let us know if you still have any issues accessing the VAT Return, and we’ll investigate further.
Posted Jun 24, 2020 - 11:02 UTC
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted Jun 24, 2020 - 10:27 UTC
Update
We’re currently aware of an issue preventing users from loading the MTD VAT screen. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Jun 24, 2020 - 09:44 UTC
Investigating
We are currently investigating this issue.
Posted Jun 24, 2020 - 09:43 UTC
This incident affected: Xero.