Global: Xero - Customers are unable to access the Navigation bar
Incident Report for Xero
Resolved
Our team has resolved the issue impacting customers trying to access the Dashboard Navigation bar. We apologise for any inconvenience this has caused.

Our technical team identified this was caused by poor network connectivity and has restored service.
Posted Jan 08, 2024 - 04:37 UTC
Investigating
We are aware customers are currently experiencing issues when trying to access the Dashboard Navigation bar. Our team is investigating this with urgency.

Status Last Reviewed: 4:05am UTC.
Posted Jan 08, 2024 - 04:08 UTC
This incident affected: Xero Platform and Settings.