Some users experiencing slowness in Xero
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was causing some users to experience slowness in Xero.
Posted May 13, 2021 - 04:20 UTC
Monitoring
A fix has been implemented and we're monitoring results.
Posted May 13, 2021 - 04:15 UTC
Identified
Our Product Team have identified the cause, and are working to fix the issue causing some users to experience slowness in Xero as soon as possible.
Posted May 13, 2021 - 02:55 UTC
Investigating
We’re currently aware of an issue causing some users to experience slowness in Xero. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted May 12, 2021 - 23:50 UTC
This incident affected: Xero Platform and Settings.