AWS outage impacting multiple products across Xero
Incident Report for Xero
Resolved
This incident has been resolved.
Posted Jun 10, 2022 - 05:19 UTC
Monitoring
AWS has implemented a fix and is monitoring the results.
Posted Jun 10, 2022 - 04:45 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 10, 2022 - 04:17 UTC
Update
We are continuing to investigate this issue.
Posted Jun 10, 2022 - 03:28 UTC
Update
We are continuing to investigate this issue.
Posted Jun 10, 2022 - 03:24 UTC
Investigating
We’re currently aware of an AWS outage preventing customers from performing tasks in multiple Xero products. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Jun 10, 2022 - 02:59 UTC
This incident affected: Xero Platform and Settings, WorkflowMax and Xero Partner Products & Tools (Xero Practice Manager (XPM), Xero HQ).