Global: Invoicing - Some customers are experiencing errors or slowness when accessing Invoicing in Xero

Incident Report for Xero

Resolved

Our team has resolved the issue impacting some customers experiencing slowness or errors when accessing invoicing in Xero. We apologise for any inconvenience this has caused.

Our technical team identified this was caused a momentary period of issues with network connectivity, and our team has restored service.
Posted Jul 14, 2026 - 06:43 UTC

Investigating

We are aware of some customers experiencing slowness or receiving errors when accessing Invoicing in Xero. Our team is investigating this with urgency.
Posted Jul 14, 2026 - 04:57 UTC
This incident affected: Core Xero Products (Invoicing, Bills & Quotes).