Xero Performance issues
Incident Report for Xero
Resolved
This incident has been resolved.
Posted Nov 17, 2021 - 00:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 16, 2021 - 23:38 UTC
Investigating
We are currently aware that users may be experiencing issues navigating through the platform, including receiving error messages and general slowness.
The Product team are investigating this with urgency.
Apologies for the inconvenience this is causing you - we'll update you as soon as we have any further updates.
Posted Nov 16, 2021 - 23:11 UTC
This incident affected: Xero.