Global: Dashboard - Customers maybe experiencing performance issues
Incident Report for Xero
Resolved
Our team has resolved the performance issues some customers experienced accessing the dashboard. We apologise for any inconvenience this has caused.

Our technical team identified this was caused by poor network connectivity and has restored service.
Posted Sep 06, 2023 - 02:49 UTC
Investigating
We are aware some customers trying to view the dashboard might be experiencing slowness and performance issues. Our team is investigating this with urgency.

Status Last Reviewed: 2:22am UTC
Posted Sep 06, 2023 - 02:23 UTC
This incident affected: Xero Platform and Settings.