Some users experiencing multiple issues when using Xero Payroll
Incident Report for Xero
Resolved
Our Product Team have resolved all the issues some users experienced using Xero Payroll.

If you're still have problems, please clear your cookies and cache. Instructions on how to do this are below.

If you continue to have issues, please let us know.

Xero Help Centre: https://help.xero.com/ClearCookiesCache
Posted Jun 12, 2017 - 23:42 UTC
Update
Our Product Team are still working to fix all the issues with Xero Payroll.

Some customers have let us know that clearing their cookies and cache has resolved some of the issues for them so we recommend doing this if you haven't already. Instructions on how to do this in your browser are below:

Xero Help Centre: https://help.xero.com/ClearCookiesCache

We'll let you know once we have any more information.
Posted Jun 12, 2017 - 23:20 UTC
Identified
Our Product Team have identified the cause of these issues are working on a resolution. We'll update you here once we have any more updates for you.
Posted Jun 12, 2017 - 23:01 UTC
Investigating
We're currently aware that some customers are experiencing multiple issues in Payroll including:

- Some pages displaying incorrectly
- Not being able to access Pay Runs
- Not able to update Superannuation details

Our Product Team are currently looking into this and we'll let you know as soon as we have any updates. Please accept our apologies for any inconvenience this is causing.
Posted Jun 12, 2017 - 22:46 UTC