Users unable to create Batch Payments
Incident Report for Xero
Resolved
This incident has been resolved.
Posted Mar 03, 2021 - 19:57 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 03, 2021 - 19:26 UTC
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted Mar 03, 2021 - 18:22 UTC
Investigating
We are currently investigating this issue.
Posted Mar 03, 2021 - 15:54 UTC
This incident affected: Xero.