Global: Xero - Some customers may be experiencing errors in Xero
Incident Report for Xero
Resolved
Our team has resolved the issue causing some customers to encounter errors in Xero. Our technical team identified this was caused by poor connectivity and has restored service. We apologise for any inconvenience caused.
Posted Sep 26, 2024 - 13:05 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 12:34 UTC.
Posted Sep 26, 2024 - 12:34 UTC
Investigating
We are aware customers trying to load pages in Xero in are experiencing errors. Our team is investigating this with urgency.

Status Last Reviewed: 12:14 UTC.
Posted Sep 26, 2024 - 12:15 UTC
This incident affected: Xero Platform and Settings.