Global: Xero App Store - Currently unavailable
Incident Report for Xero
Resolved
Our team has resolved the issue impacting customers trying to access the Xero App Store. We apologise for any inconvenience this has caused.

A product release caused this feature to become unavailable. We've rolled back the release and services are back to normal.
Posted Nov 15, 2023 - 01:57 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 1:28 am UTC
Posted Nov 15, 2023 - 01:29 UTC
Investigating
We are aware customers trying to access the Xero App Store are currently experiencing an error message. Our team is investigating this with urgency.

Status Last Reviewed: 1:18 am UTC
Posted Nov 15, 2023 - 01:18 UTC
This incident affected: Xero Platform and Settings.