Our team has resolved an issue impacting some customers trying to navigate Xero, and using some products including invoicing.
A product release caused some customers to experience errors. We have rolled back the release and customers can use these products as expected. We apologise to our customers and thank you for your patience during this time
Status Last Reviewed: 6:44am UTC
Posted Oct 02, 2024 - 06:44 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 02, 2024 - 06:20 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results. We apologise for the issue this has caused.
Status Last Reviewed:
Posted Oct 02, 2024 - 06:13 UTC
Update
We’re aware some customers continue to experience errors navigating Xero including errors loading the dashboard, working in bills, new invoicing and in some other products.
We know when there’s an issue, customers want as much information as possible about what is happening and when the issue will be resolved. Our team is continuing to investigate this with urgency.
We apologise to our customers and thank them for their patience during this time.
Posted Oct 02, 2024 - 04:48 UTC
Update
We are continuing to investigate this issue. We thank customers for their patience during this time and apologise for the inconvenience.
Status Last Reviewed: 3:48am UTC
Posted Oct 02, 2024 - 03:49 UTC
Update
We are continuing to investigate this issue. We thank customers for their patience during this time and apologise for the inconvenience.
Posted Oct 02, 2024 - 03:36 UTC
Update
We are continuing to investigate this issue. We thank customers for their patience during this time and apologise for the inconvenience.
Status Last Reviewed: 3:48am UTC
Posted Oct 02, 2024 - 03:22 UTC
Investigating
We are aware some customers trying to navigate in Xero are experiencing errors. Our team is investigating this with urgency.
We thank customers for their patience during this time and apologise for the inconvenience.
Status Last Reviewed: 3:57am UTC
Posted Oct 02, 2024 - 02:05 UTC
This incident affected: Xero Platform and Settings and Core Xero Products (Invoicing, Bills & Quotes).