Global: Projects - Creating and changing Projects

Incident Report for Xero

Resolved

Our team has resolved the issue causing some customers to receive an error when creating new Projects. There may be some delay in changes being populated as the system catches up. We apologise for any inconvenience this has caused.
Posted Feb 26, 2026 - 12:01 UTC

Investigating

We are aware that some customers are experiencing errors when trying to creating a new Project and may see delays when making changes to existing Projects. Our team is investigating this with urgency.
Posted Feb 26, 2026 - 09:29 UTC
This incident affected: Core Xero Products (Projects).