Can't access Contacts screen
Incident Report for Xero
Resolved
This incident has been resolved.
Posted Nov 18, 2021 - 22:31 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2021 - 22:21 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 18, 2021 - 22:13 UTC
Investigating
We’re currently aware of an issue preventing users from accessing the Contacts screen. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Nov 18, 2021 - 22:00 UTC
This incident affected: Xero.