Global: Contacts - Some users are unable to create a new contact in Xero
Incident Report for Xero
Resolved
This incident has been resolved.

A product release caused this feature to become unavailable. We've rolled back the release and services are back to normal.
Posted Nov 21, 2023 - 04:21 UTC
Investigating
We are aware that some users are unable to create a new contact in Xero. Our team is investigating this with urgency.

Status Last Reviewed: 1:56am UTC
Posted Nov 21, 2023 - 01:56 UTC
This incident affected: Core Xero Products (Contacts).