Some users are experiencing slowness and errors in WorkflowMax and Xero Practice Manager
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was causing some users slowness in WorkflowMax and Xero Practice Manager.

Please let us know if you still have any issues, and we’ll investigate further.
Posted Feb 19, 2020 - 22:50 UTC
Update
We are continuing to investigate this issue.
Posted Feb 19, 2020 - 22:40 UTC
Investigating
We’re currently aware of an issue where some users are experiencing slowness and errors in WorkflowMax and Xero Practice Manager. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Feb 19, 2020 - 22:32 UTC
This incident affected: Partner Tools & WorkflowMax (Practice Manager and WorkflowMax).