Global: Homepage - some bank account widgets aren't loading

Incident Report for Xero

Resolved

Our team has resolved the issue impacting customers trying to view bank account widgets on the Homepage. We apologise for any inconvenience this has caused.

A product release caused bank widgets in Homepage to become unavailable.
Posted Feb 03, 2026 - 22:33 UTC

Monitoring

Our team has implemented a fix and we are currently monitoring the results.
Posted Feb 03, 2026 - 22:17 UTC

Identified

We have identified what is impacting customers trying to view bank account widgets on the Homepage .

This is our top priority and we will update you as soon as we can.
Posted Feb 03, 2026 - 21:55 UTC

Investigating

We are aware some customers trying to view bank account widgets on the Homepage are experiencing an error. Our team is investigating this with urgency.
Posted Feb 03, 2026 - 21:44 UTC
This incident affected: Xero Platform and Settings.