Customers may be experiencing errors and slowness across Xero
Incident Report for Xero
Resolved
Our team has resolved the performance issues some customers experienced across Xero. We apologise for any inconvenience this has caused.

Our technical team identified this was caused by poor network connectivity and has restored service.
Posted Jan 25, 2024 - 04:08 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 3.30am UTC
Posted Jan 25, 2024 - 03:31 UTC
Investigating
We are aware customers may be experiencing error messages and general slowness across Xero. Our team is investigating this with urgency.

Status Last Reviewed: 3.10am UTC
Posted Jan 25, 2024 - 03:11 UTC
This incident affected: Xero Platform and Settings.