Some users are getting an error when switching organisations in Xero
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was preventing a small number of users from switching organisations in Xero..

Please let us know if you still have any issues accessing Xero, and we’ll investigate further.
Posted Oct 21, 2020 - 05:22 UTC
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted Oct 21, 2020 - 04:42 UTC
Investigating
We’re currently aware of an issue preventing a small number of users from switching organisations in Xero. Our Product Team is investigating this with urgency.

In the meantime, you can switch organisations from the My Xero page.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Oct 21, 2020 - 04:09 UTC
This incident affected: Xero.