Some users are experiencing performance issues in Xero
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that some users were experiencing slowness in Xero.

Please let us know if you still have any issues using Xero, and we’ll investigate further.
Posted Feb 26, 2020 - 04:41 UTC
Update
Our Product Team are doing everything they can. Thanks for your patience.
Posted Feb 26, 2020 - 04:11 UTC
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted Feb 26, 2020 - 03:28 UTC
Update
We are continuing to investigate this issue.
Posted Feb 26, 2020 - 03:08 UTC
Investigating
We’re currently aware of a small number of users experiencing performance issues in Xero. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Feb 26, 2020 - 03:05 UTC
This incident affected: Xero.