Some users are experiencing issues with the Navigation Menu and buttons in some areas of Xero
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was preventing users from clicking links in the Navigation menu and buttons in some areas of Xero.

Please make sure to clear your browser's cookies and cache and let us know if you still have any issues with this, and we’ll investigate further.

Xero Central article: https://central.xero.com/s/article/Clear-Cookies-and-Cache
Posted Nov 24, 2020 - 01:55 UTC
Update
Our Product Team are doing everything to resolve the issue with the Navigation menu and buttons in Xero. Thanks for your patience.
Posted Nov 24, 2020 - 01:28 UTC
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted Nov 24, 2020 - 00:31 UTC
Update
We’re currently aware of an issue with the Xero Navigation Menu. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Nov 23, 2020 - 23:17 UTC
Investigating
Some users may be experiencing issues with the Xero Navigation Menu, we are investigating and will post an update as soon as we have more information.
Posted Nov 23, 2020 - 22:26 UTC
This incident affected: Xero.