Global: Xero Central - Some customers are unable to raise cases
Incident Report for Xero
Resolved
Our team has resolved the issue customers experienced when they were unable to raise cases in Xero Central. We apologise for any inconvenience this has caused.

A product release caused this feature to become unavailable. We've rolled back the release and services are back to normal.
Posted Jan 17, 2024 - 02:32 UTC
Investigating
We are aware some customers are unable to raise a case in Xero Central. Our team is investigating this with urgency.

Status Last Reviewed: 1:43am UTC
Posted Jan 17, 2024 - 01:43 UTC
This incident affected: Xero Central.