Global: HQ - Some customers are unable to view the client tab
Incident Report for Xero
Resolved
Our team has resolved the issue impacting customers trying to trying to view the client list in Xero HQ. We apologise for any inconvenience this has caused.

Our technical team identified this was caused by poor network connectivity and has restored service.
Posted May 25, 2023 - 05:23 UTC
Investigating
We are aware of an issue where some customers trying to view the client list in Xero HQ are experiencing issues. Our team is investigating this with urgency.

Status Last Reviewed: 4:17am UTC
Posted May 25, 2023 - 04:17 UTC
This incident affected: Xero Partner Products & Tools (Xero HQ).