Global: Invoicing - Sending Invoices via mobile app

Incident Report for Xero

Resolved

Our team has resolved the issue causing some customers to encounter errors when trying to send Invoices via our mobile apps. We found the issue was related to a recent release which was rolled back. We apologise for any inconvenience this has caused.
Posted Jul 31, 2025 - 10:28 UTC

Monitoring

Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 10:07 UTC.
Posted Jul 31, 2025 - 10:07 UTC

Investigating

We are aware that some customers trying to send Invoices via our mobile apps are encountering error messages. Our team is investigating this with urgency.

Status Last Reviewed: 09:50 UTC
Posted Jul 31, 2025 - 08:26 UTC
This incident affected: Xero Mobile Apps (Xero Accounting Mobile App).